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About This Tutorial

This manual is intended for users who are new to website design but who already possess some computer experience as well as basic Adobe Photoshop (or Macromedia Fireworks) skills.  Additionally, experience with Microsoft Word’s Styles and Tables features is helpful.  Finally, to publish a website, you need to be familiar with FTP software such as that used on UW computers.  If you have not used this type of program before, consult with a computer instructor, UW help-desk person, or computer-savvy friend to show you the ropes.

The instructions that follow are designed to get you up to speed as quickly as possible, covering the minimum features necessary to publish a site.  You are also encouraged to augment the information in this manual by exploring Dreamweaver’s own Tutorials sections and website (see the Resources section).

Tutorial Overview

This tutorial will teach you to create a website from scratch.  You will begin by gathering the content to be used in the site, after which you will set up a file system to organize your site’s components.  Next, you will design and create a page layout.  Following that, you will add content to your site and create hyperlinks to connect it all together.  Last, you will publish your site on the Internet.

Prepare – Gathering Content

Before you begin your website, it is a good idea to gather the content you’ll be using.  This way, you’ll have an idea of what the site will contain, which will help you design your pages to best accommodate the content.

TIP:  Google’s Image search feature is a terrific tool for locating graphics and photos.  At google.com, click on Images to search.
Graphic Formats

A key design consideration when constructing a website is the speed with which your pages load.  Pages that contain mostly text load quickly; pages with lots of graphics load slowly.  You can minimize the time needed to load graphics-intensive pages by using file formats such as .gif, .jpg, and .tiff, which are small and load quickly.  Do not use bitmap (.bmp) files because of large file sizes.  Additionally, Photoshop files (.psd, et al.) are incompatible with web browsers.

Managing Graphics Files

Editing graphics for a website is often done in Photoshop.  Because of Photoshop file size and their incompatibility with web browsers, all of your graphics must be converted to one of the file formats suggested above.

TIP:  Web designers often create a “prod” folder (short for production) for all of the “raw” and Photoshop files that will later be edited and/or converted to web-friendly formats.  

Create your own prod folder and place these types of files in it.

As you will learn later, a separate prod folder will simplify the process of publishing your site to the web.
Which File Format?

Choose the optimum file format based on the following table:


	Type of Graphic
	Preferred Format
	Notes

	Photograph
	.gif or .jpg
	In Photoshop, to save files optimized for the web, go 
File > Save for Web (Alt+Ctrl+Shift+S)

	Illustration
	.gif or .jpg
	See above.

	Line Drawing 
or Logos
	.tiff
	In Photoshop, so save a line drawing as a .tiff file, go
File > Save, select the .TIFF format, and click OK.


Text Content

Text content can be saved in any format (e.g., MS Word) and is easily pasted into your website.

Create Your Site Files

Once you have gathered together the content, it’s time to create your site’s folder structure, which will contain all page files and graphics.  

Step-by-Step Instructions

Following are instructions to guide you through the process, which consists of entering information and choosing options in a step-by-step “wizard”:

1. Open Macromedia Dreamweaver MX.

2. Click on the Site pulldown menu and select New Site.  A dialog box called Site Definition will appear.

3. Type in a name for your site and click  Next.

TIP:  Web addresses are case-sensitive!  To avoid confusion, use lower case letters only and do not use spaces.  Follow this rule for all web page and file names.
4. The second dialog box asks if you would like to use a server technology.  The default is no; leave it as-is and click the Next button.  

5. The third dialog box prompts you to choose where you wish to edit your site.  If not already selected, choose the first option, “Edit local copies on my machine, then upload….”
6. Still in the third dialog box, click on the “file” icon, navigate to your UWTC “U” drive, and create a new folder called sites.  Double-click on this new folder and click the Select button.

Back in the dialog box, click the Next button.

7. Now in the fourth dialog box, you are prompted to select a method of connection to your remote server.  Choose the option, None (you will publish manually with FTP).  

8. The next field determines where Dreamweaver will assume your files are located (and where files will be saved). Click on the “file” icon, navigate to the website folder you created in Step 6, click the Select button, then click Next.

9. In the fifth dialog box, accept the default selection “No, do not enable check in and check out.” and click on the Next button.

10. The final dialog box lists a summary of your site.  Preview it and click the Done button.

Organizing your Files

Save all of your web pages in the new site folder you created above.  This is done not only to keep your site organized into one common folder, but to ensure that your site works properly when you publish it to the web.

Save all of your graphics files in a folder entitled “images.”  Use the following instructions to create an images folder:

11. In Macromedia, on the right margin of the screen, a toolbar called “Files” lists your site folders and files:
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12. Right click on the site folder and select New Folder.

13. Name the folder images and use it as a repository for your site’s graphics files.

NOTE:  To ensure proper transfer to the web, save all of your graphics in this images folder.  Keep the raw and Photoshop files out of this folder – this is what the “prod” folder is for (see Preparation – Gathering Content).  

Keeping every single file in your site folder makes transferring your site to the web via FTP an unnecessarily long process because of the sheer volume of data that must be uploaded.
Page Design

Now that you have created the folders, it’s time to turn your attention to your site’s layout.  Principles of web design and usability are beyond the scope of this tutorial, but links to information on the topic may be found in the Web Resources section.  This section outlines the basic strategy used to design the majority of web pages.  The key to this technique is the use of tables.

Tables – The Core of Web Design

Web designers create tables to place the various content elements of the pages on the screen.  By making the table borders invisible, the user sees only a nice, organized layout.  Dreamweaver allows you to create this layout quickly and easily.  Note that there are a number of methods that achieve the same purpose; the following instructions are just one of many.
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TIP:  A great way to familiarize yourself with tables is to find a site such as www.ibm.com on the web, save the home page, and open it up in Dreamweaver, which will reveal its table structure.  Be sure Dreamweaver is in Layout view.  Click on the Layout tab as shown here:

Layout Procedure Step-by-Step

Part 1: Sketch the Layout

You may find that it is easier to first sketch a layout on paper and then recreate that design in Dreamweaver.  When you
sketch, address only the overall shape and organization you wish to achieve; leave out the details.  The following is an example of a sketch:
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Part 2: Create the Layout in Dreamweaver

The following instructions will guide you through the process of creating your layout design in Dreamweaver.  You will first change some settings that are useful when doing layout work.  Next, you will create your site’s overall usable space with the Draw Layout Table.  Finally, you will add to the layout table the individual cells that will contain content.

14. Open Dreamweaver MX.

15. Click on the Layout tab at the top of the screen, as shown here:
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16. Click on the Layout View text to the right of the “Standard View” button, as shown above in Step 2.

17. Click on the Windows pulldown menu and select Properties.  

The bar that appears at the bottom of the window is useful for layout chores.

18. Press Ctrl+Alt+R to show rulers.  Then, right click on the ruler and select Pixels.  

Website dimensions are usually measured in pixels; the rulers come in handy for layout.

19. Click on the green, gray, and white Draw Layout Table icon located just to the right of the Layout View button in the diagram above in Step 2.

20. Now, draw a Layout Table by single clicking anywhere in the page area on the screen.  Don’t worry about its size; you will adjust it in the next step.

21. In the Properties box at the bottom of the screen, locate the Width item (see illustration below).  Make sure the Fixed button is selected, then enter 770 pixels in the field.  Also enter 600 pixels in the Height field.  (Layouts with fixed dimensions are easier to manage.)
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NOTE:  When creating a site, web designers consider the oldest computer equipment their viewers might own.  The smallest computer monitors still commonly used have 800 by 600 pixel screens, so page dimensions are limited to this size.  However, 
because certain web browser software scroll bars take up some of this space, the full page does not display properly.  You can accommodate this problem by using a fixed width of a smaller dimension, hence the 770 pixel width instead of 800.
22. Now, with a layout table created, click on the blue and white Draw Layout Cell button, which is just to the right of the Draw Layout Table button (see diagram above in Step 2).  

23. Based on your layout sketch, draw cells in the appropriate positions in the layout table.  Use the Properties section at the bottom of the screen to fine-tune the dimensions.  As an example, the following diagram shows cells that correspond to the layout sketch shown above:
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NOTE:  The white boxes in the diagram above denote layout cells; the gray areas have not yet been filled with cells.
TIP:  Get in the habit of testing your pages in your browser!  Whenever you make changes or additions to your page, press F12 to view them “live” in your browser window.
TIP:  Dreamweaver allows you to easily split cells.  As an example, consider the navigation bar in the above screen shot, which began as a single cell but was then divided into six evenly sized cells.  This procedure functions just like in MS Word.

1. First, create a single cell that will contain all links.

2. Click on the Standard View button to the left of the Layout View button (see diagram above in Step 2).  The layout will now appear strictly as a table.* 
3. Right click on the cell and select Table > Split Cell.  

4. In the Split Cell dialog box that appears, configure the rows and columns as needed and click OK.

* Web design programs allow you to view your site as tables; Dreamweaver also allows this.  However, Dreamweaver’s Layout View and Draw Layout Table feature adds more flexibility to and simplifies the application of tables and cells into a web page.  You can create tables more conventionally (e.g., by using the same methods in MS Word or other web programs) when in Standard View.

24. Once you have configured the layout, save the page.

NOTE:  Dreamweaver does have a template feature; however, its description is beyond the scope of this manual.  An alternative means of keeping each of your site’s pages consistent is to finalize the layout design, save it, and open it to copy it with a “Save As” when adding new pages.  Make sure you have also created the links in your navbar (see the Basic Dreamweaver tools section).
Use Basic Dreamweaver Tools

Once you have created your website’s layout, it’s time to add the content by using layout cells to position your content on each page and placing either text or graphics in the cells as necessary.  The following instructions describe how to properly set up a default home page and incorporate basic web features such as text and graphics hyperlinks.

Name Your Home Page “index.htm”

When you type in a URL while surfing the Internet, that address usually doesn’t point to a specific page; instead, it points to a folder on the computer server that contains all of that website’s individual pages.  But even though a single website may contain hundreds of pages, the first page displayed is always the home page.  How does this happen?

When first connected to a website, your browser looks for a specific file called index.htm.  This is by default the first page displayed.  If you do not have a file with this name, your users will instead see a list of every file and graphic in your website, which is neither very useful nor appealing.  

Therefore, name your home page index.htm so that everyone who views your site starts off on the right page.

TIP:  You can use either the .htm or .html extension when naming your pages; however, it is a good idea to get in the habit of using only one or the other.  Why?  Because when you type a full URL whose file extension is actually .html but you type in .htm, the browser won’t find the file.  The same is true if you do the opposite and type in a full address ending in .htm for a page whose extension is actually .html.

Add Graphics with Drag-and-Drop

Dreamweaver allows you to quickly and easily add graphical elements to web pages.  Your site folders and files are displayed in the Files section located on the right side of the screen.  Simply click and hold the button down on the graphic file you wish to use, drag it to its destination, and release the mouse button to “drop” it in place.

Create Hyperlinks

The following step-by-step instructions guide you through the process of creating text and graphic hyperlinks in your site.

To Add a Text Link

25. Position the cursor in the text where you wish to add a word or phrase that is also a hyperlink.  Do not type this word or 

phrase yet; just place the cursor.

26. Click on the Insert pulldown menu and select Hyperlink.  The following dialog box will appear:
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27. In the Text box, type the word or phrase that you wish to be a hyperlink.  For example, if you have written a sentence that says, “Click here for more information,” and you wish to make the word “here” a hyperlink, then you would have first placed the cursor after the word “click,” and now should type the word “here” into the text box.

28. In the Link box, type in the full link (including “http://”).  If you are linking to a page that already exists in your website folder, click on the folder icon, browse to that page, and select it.

NOTE: Remember, all files and graphics belonging to your site must be contained within your site’s folder.  If you link to a file on your local drive or otherwise not in the site folder (except other websites), the link will be broken when you publish the site. 
29. In the Target field, select the way you wish to display the linked page.  For example, you can choose to open the link in a brand new browser window.  The default, _self, simply opens the page over the existing one; the user can use their browser’s “back” button to return.  Following is a list of the options:

· blank loads the linked file into a new, unnamed browser window. 

· _parent loads the linked file into the parent frameset or window of the frame that contains the link. If the frame containing the link is not nested, the linked file loads into the full browser window.


· _self loads the linked file into the same frame or window as the link. This target is the default, so you usually don’t need to specify it.


· _top loads the linked file into the full browser window, thereby removing all frames.
30. In the Title field, type in the alternate text you wish to display in a small pop-up when the user “mouses over” that link.

TIP: An element of good web design is the use of text hyperlinks that properly indicate the nature of the link destination and content to the user.  If you choose your wording adequately, the alternate text in the Title field is unnecessary.  Still, it is a good idea to use the Title field as a matter of habit and should always be done for hyperlinks that are graphics, not text.
31. Leave the Access Key blank.  (The Access Key feature allows you to assign a command key definition to the link.  To learn more about it, press F1 in Macromedia and search the Help files.)

32. Click OK.  Your link will now appear in blue text and underlined.

To Add a Hyperlink – Graphics

33. Position the graphic on the page.

34. Single-click the graphic to select it.

Now, down at the Properties window located at the bottom of the screen (see below).  If the Properties window does not appear when you select the graphic, click on the Window pulldown menu and select Properties.

[image: image7.jpg]thotys (1 chmgs

Couge TN W[ Soluenitootedosoot G ) 4 [Fwerclom o]
: P )
Voowe|  Twe[ ] Bedelo

F IO tspeee|— awse SO fnfows





35. To link to another page within your site, click and hold the “bull’s-eye” icon to the right of the Link field, drag your mouse over to the Files window on the right side of the screen, select the appropriate page file, and release the mouse button.  The following screenshot illustrates:
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36. In the Alt field, type in the text you wish to appear when the user “mouses over” the graphic.  From a usability standpoint, this information should not be omitted.

TIP:  If you decide to use icons or other images as links, it is a good idea to assume that some of your users will be unable to determine what those graphics indicate or, sometimes, that they are even links to begin with.  For this reason, consider adding a text link beneath the graphic that takes the user to the same page as the graphic link.
37. Test your link by pressing F12 to view your page in your browser.

Suggested Dreamweaver Features

The preceding instructions barely touch the surface of Dreamweaver’s capabilities, although with them you can create web pages that are perfectly functional.  If your design concepts contain elements with greater complexity than simple layout and link features can manage, you are encouraged to browse Dreamweaver’s Tutorials to learn more about the following helpful features:

· Layers and Behaviors
The Layers feature allows you to add content that overlaps other content.  With the addition of Behaviors, you can create effects such as making certain content visible or invisible based on the user’s mouse movements or input.

· Hotspot Links
Dreamweaver allows you to select discrete portions of a graphic and make them “hotspots,” which are hyperlinks.  For example, you may have visited a website that prompts you to select your area of the country, either by region or state; typically, a map of the U.S. is used.  To allow users to click to a page directly related to their state,  hotspots are created for each state so that when the user clicks on, say, Washington state, a page dedicated to the state opens.  
· Create a “Slideshow”
Ever been to a web page that allows you to view multiple photographs by clicking “next” and “back” arrow buttons?  This feature is called a “slideshow” and is handy if you have a lot of pictures to show.

Actually, Photoshop’s slideshow feature is simpler than Dreamweaver’s; you can create it in Photoshop and then easily add it to your site.  Gather your pictures into one file, open Photoshop, click on the File pulldown menu, select Automate, and then Web Photo Gallery.  Follow the instructions that appear.
· “Pop-up” Menus
Pop-up menus are similar to rollover images in that a set of links drops down when the user mouses over a navigational link (see www.xo.com for an example).  This feature is fairly straightforward to create and allows you to compactly present many links from a single page.  The navigation bar at www.xo.com illustrates another effective method of displaying the contents of a navigation bar’s links and allows the user to skip the main link and instead go directly to the secondary link.
Publish Your Site: FTP

Taking your site “live” on the web requires File Transfer Protocol (FTP) software.  FTP software simply allows you to access files on any computer connected to the Internet to which you are given access.  Files of any type can be moved to your PC from a computer halfway around the world with a simple drag and drop move.  

As a UW student, you have been allotted disk space on a University computer with which to keep files and publish websites.  Thus, to publish a site for all the world to see, you need only transfer your site folder from your “U” drive to your student disk space.  This is achieved by merely dragging and dropping the folder into the appropriate directory that appears when you access your disk space with FTP software.

UW computers are loaded with an FTP software program called SSH Secure Shell; this program is also available to students for download at no charge or on compact disk from the UW Bookstore for a nominal fee (see Web Resources for more information on obtaining SSH Secure Shell for your personal computer).  Any FTP program should enable you to transfer your site.

Upload your Site – Step-by-Step

38. Open SSH Secure Shell or other FTP program and access your disk space by connecting to Dante.

39. In the FTP window containing your student disk space (right-hand side in SSH Secure Shell), locate the folder entitled “public_html”.

40. In the FTP window containing your computer files (left-hand side), click on My Network Places and navigate to your space on the “U” drive.

41. Click on your site folder, hold the mouse button down, drag it to the public_html folder and “drop” it in by letting up on the mouse button.  The FTP software will commence transferring the entire folder into public_html.  

NOTE: If you saved all of your bitmap and Photoshop files in your site folder, this transfer will take a very long time, especially if you have a dial-up connection and are working from home (actually, even a DSL connection will be quite slow to transfer massive Photoshop files).

42. After your site has been uploaded, open your web browser and type in the following address:

http://students.washington.edu/
your_MYUW_login_name/site_folder_name


Your web site will appear “live” and is now accessible to anyone on the planet with a computer with connected to the Internet.

Web Resources

See the following web resources for more information on Dreamweaver, website usability, help with design, learning HTML, and how to obtain FTP software from the UW.

Dreamweaver Links

· Dreamweaver Support Site: http://www.macromedia.com/support/dreamweaver/
tutorial.html  

· Dreamweaver Tutorial Documents (also see online help by pressing F1): http://download.macromedia.com/pub/dreamweaver/
documentation/dwmx_tutorials.zip 

UWTC Professors’ and Others’ Usability Papers

· David Farkas, Ph.D., UW Professor
http://www.techcomm-online.org/issues/
v47n3/pdf/0410.pdf 

· Tom Williams, Ph.D., UW Professor
http://www.techcomm-online.org/issues/
v47n3/pdf/0411.pdf 
· Jan Spyridakis, Ph.D., UW Professor
http://www.techcomm-online.org/issues/
v47n3/pdf/0419.pdf
· Jakob Nielsen, Usability Expert
http://www.useit.com/alertbox/ 
Other Helpful Sites
· Web Design Help 
http://www.webmonkey.com 

· HTML Tutorial 
http://www.htmlgoodies.com/primers/basics.html
· HTML Tutorial http://archive.ncsa.uiuc.edu/General/Internet/WWW/HTMLPrimerP1.html 

UW Free FTP Software

· FTP Software http://www.washington.edu/computing/software/uwick/ 

· Information on publishing websites at the UW
http://students.washington.edu/
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